
Using Excel to 
Troubleshoot EMIS Data



The Ohio Department of Education funds development of EMIS training materials 
as part of the EMIS Alliance grant. There is an expectation that ITCs will utilize these 
materials in training provided to your districts. That said, there are restrictions on 
use of the EMIS Alliance materials as follows: Materials developed as part of the 
EMIS Alliance program must be provided at no cost to your training participants. If 
you utilize the EMIS Alliance training materials – in whole or in part – you must not
charge participants a fee to attend the class where the materials are used. Likewise, 
you may not use the materials or any portion thereof in any event where a fee is 
charged to attend. Exceptions must be approved in writing by the Department of 
Education in advance of scheduling/promoting any event which may violate these 
restrictions.

Questions regarding appropriate use of EMIS Alliance materials, or requests for 
exception to the restrictions noted above, should be directed to Melissa Hennon 
[Melissa.Hennon@education.ohio.gov].

2

mailto:Melissa.Hennon@educatioin.ohio.gov


Overview

• Basic, Intermediate, and Advanced Excel techniques can be 
used to analyze EMIS data from Student Information Systems 
(SISs), from the Data Collector, and on ODE EMIS reports

• This session will demonstrate Excel functions and practical 
applications that can be helpful in all phases of the EMIS 
data review process 
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Outline

• Staff and Course Collection Best Practices

• Prepare the CI and CK files for sharing with others in your district  
• Use Conditional Formatting

• Add data with VLOOKUPS 

• Create a PivotTable 

• Review prepared Staff Demographic (CI) and Staff Employment 
(CK) files 

• Access Excel recorded sessions 
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Sharing Staff Data 

• Staff data and Course/Student data originate in separate source 
systems 

• The Staff and Course (L) Collection is where the staff, course, 
and student course assignment data meet
• When initially running this collection, the results can sometimes be 

messy

• Sharing staff EMIS data with district staff can be helpful when 
correcting and verifying the data

• This is not a comprehensive staff and course training but rather 
some suggestions on using Excel to work through the data
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Troubleshooting Staff and Course Data

• Data in the SIS and the Staff EMIS system should be updated 
and current for all LEA types

• Use a systematic approach when working through the Staff 
and Course Collection

1. Resolve Level 1 Validations 

2. Resolve Excluded Records

3. Resolve any remaining Missing Staff 

4. Share the CI and CK files to verify the data to be current, correct, 
and complete

5. Review other Submission Files and Level 2 Reports 
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Resolve Level 1 Validations
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Fix Level 1 Validations 
first because they can
cause Excluded Records 
and Missing Staff

If you have Level 1 
Validations, a link 
will appear



Resolve Excluded Records and Missing Staff
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Excluded Records are not 
included in the data that 
is reported to ODE

Staff Missing includes 
those reported in a prior 
collection without a 
separation date and who 
are currently not being 
reported



Submission Files, cont’d
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Start by opening the Staff Employment (CK) file, 
we will open the Staff Demographic (CI) later

We are going to demonstrate some Excel functions
Using the CI and CK files but all files should be reviewed



Quick Check • Have you processed a staff and course 
collection with current data? 

• Have you cleaned up your Level 1 
Validations?

• Have you resolved your Excluded 
Records and Missing Staff? 

The Staff and Course 
Collection includes data from 
two separate source systems 
and involves more district 
staff to review the data. It is 
best to work through errors, 
excluded records, and missing 
staff before attempting to 
review the remaining 
submission files.
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Preparing the Staff 
Employment (CK) File
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Files to Open 

• Staff Employment Record (CK)

• Your ITC will provide you with two additional files-
• Position Codes as of 10_12_2021

• Assignment Areas as of 10_12_2021

12



Prepare the CK file
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With the Staff Employment 
(CK) file open, see that the 
values in the Position Code 
column appear as =“230” 
which will prevent the 
VLOOKUP from working 

In the next series of slides
we will reformat this column  



Copy and Paste 
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1. Select the data in the Position 
Code column without selecting the 
Header. Tip- Place cursor in cell G2, 
hold down the Shift and Control 
keys and press the down arrow

2. With the data 
selected, right 
click and then 
select “Copy” 



Copy and Paste, cont’d 
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Right click again 
and select the 
“paste values” icon 



Resolve the Error Flag
3. 
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1. With the data still 
selected, an error flag 
will appear

2. Click the down 
arrow and select 
“Convert to Number”

3. This will shift the 
numbers in the 
column to the right  



Format Cells 
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1. One last time, right 
click  while the data is 
still selected and 
choose “Format Cells” 

2. In the Format Cells 
prompt, select 
“Number,” then set the  
“Decimal places” to “0”, 
then click “OK”



Freeze Top Row
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1. Select the top row 
2. From the View tab, select “Freeze 
Panes” and “Freeze Top Row”



Wrap Text in Top Row
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From the Home Tab, select “Wrap Text”



Add Filters
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From the Home tab, select “Sort 
& Filter” and then “Filter” 



Sort the File
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1. Select all of the data  in 
the spreadsheet by 
clicking between the A 
and 1, or use CTRL A 

2. From the Data 
Tab select Sort  

3. In the Sort Prompt, sort by Employee 
Name and click OK  (in this demonstration 
we will use State Staff ID since names were 
removed from the DEMO file)



Conditional Formatting 
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2. From the Home tab select 
Conditional Formatting 

3. Select “Highlight Cell Rules, 
then “Duplicate Values” 

1. Select a column to highlight duplicates. 
We selected State Staff ID, but you should 
select “Employee Name”  



Conditional Formatting cont’d
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Click “OK”, then see that any staff 
member with more than one job 
record is highlighted

Since you used “Employee Name”, highlighted 
records will appear in Column E instead



Add Column for VLOOKUP
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Right click on column H then 
Select “Insert” to add a column



Name the Column and Select VLOOKUP
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1. Name the new column 
“Position Description”

2. Place cursor in 
Cell H2 then select 
the function icon. 
An equal sign will 
appear in Cell H2

3. Select VLOOKUP then OK. If 
VLOOKUP doesn’t appear in the 
list, type it in the search 
box and hit “Go” 



Begin the VLOOKUP
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1. Place cursor in the Lookup value 
box in the Function Arguments prompt, 
then click in cell G2 

2. Place cursor in the Table array Box 
then toggle to the “Position Codes 
as of 10_12_2021.xlsx” Spreadsheet



Complete the VLOOKUP Prompt
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1. Select Cell A1 and then select 
all populated cells. This will 
populate the Table Array Box

2. Enter the number 2 in 
the Col Index Num Box, 
since you want data 
from the second column

3. Type FALSE in the 
Range Lookup Box
and click OK



VLOOKUP Brings Back Position Descriptions
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Cell H2 contains the 
first matching value. 
Drag or double click 
the bottom right corner
of cell H2 to populate 
the values down



Copy and Paste Values
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To “disconnect” the data in 
Column H from the position 
codes spreadsheet, select 
Column H, then right click 
and “Copy”, then right click 
again, and paste values 
(Clipboard icon with “123”)



Repeat the VLOOKUP 

• Add a column next to the “Assignment Area” column 

• Add a title “Assignment Description”

• Place cursor in cell AA2

• Click on the Insert Function link (fx) and select VLOOKUP
• Lookup value – click in cell Z2

• Table array is data in Assignment Areas as of 10_12_2021.xlsx

• Col Index Number is 2

• Range Lookup is FALSE

• Copy values down, then copy and paste values
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Justify Columns
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Click on the triangle 
between Column A and
Row 1 to select the
entire spreadsheet

Place cursor between any 
two column headers and 
double click



Quick Check • Are you able to prepare the file with 
sorting and conditional formatting?

• Were you able to successfully complete
VLOOKUPs on the file? 

• Did you save the position code and 
assignment area code files for the next 
time you will prepare the CK file for 
review? 

When seeking feedback from 
others in your district, it is 
best to format the data to be 
more user-friendly. Simple 
Excel functions like VLOOKUP 
can additional definitions to 
columns of data that may be 
difficult to translate. 
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Reviewing the Prepared CI and CK
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Prepare the Staff Demographic (CI) File 

• Prepare your Staff Demographic (CI) file 

• Next, we will discuss ways to dig deeper into staff data
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Refer to EMIS Manual section 3.3 Staff Demographic 
Record (CI)  and other related sections 



Staff Demographic (CI) Records
Analyze the data -

• One per staff member 

• All data should be correct, current, and complete

• Pay close attention to the accuracy of -
• Education Level 

• Early Childhood Education Qualification

• Authorized Teaching Experience Years 

• Total Experience Years in Education 

• Principal Experience Years in Education 

• All records and elements should be verified

• Share this data with data owners in your LEA

• Remove Employee IDs if they contain Social Security Numbers before sending 
this to anyone for review (can leave column and header just remove values)
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Prepared Staff Employment (CK) File 
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These screenshots are from the prepared Staff Employment (CK) file

Refer to EMIS Manual section 3.4 Staff Employment 
Record (CK) and other related sections



Review the Staff Employment (CK) Records 

Analyze the data –
• At least one per staff member 

• All data  should be correct, current, and complete

• Pay close attention to 
• Position Codes and Assignment Areas

• Position FTEs and Special Education FTEs

• Pay Rate/Amount (Salaries)

• Staff with multiple job records
• Are Building IRNs, Position FTEs, and Salaries reported correctly?

• Watch for duplicate records  
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Review the Staff Employment (CK) Records, cont’d 

• Filter and highlight records with separation dates 
• Are these records for current, reportable separations? 

• Are there staff who separated that are not being reported 
appropriately? 

• All records and elements should be verified

• Share this data with data owners in your LEA 
• Remove Employee IDs if they contain Social Security Numbers before 

sending this to anyone for review (can leave column and header just 
remove values)
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Quick Check • Have you prepared your files for 
sharing and removed SSNs as 
applicable? 

• Have you included instructions to help 
understand the data in the report? 

• Have you identified the data owners in 
your school that can verify and update 
the data as needed? 

Staff EMIS data must be 
reviewed for accuracy and 
completeness. Staff EMIS data 
is used for Local Report Card 
data and for teacher 
certification purposes. It is 
important to verify this data 
with data owners within the 
LEA. 

39



Create a PivotTable 
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Super Simple PivotTable for CK Records 

• Open the Prepared Staff Employment (CK) File 

• We are going to create a PivotTable that contains 
• Position Code Descriptions

• Separated by Building and District IRNs

• Summed by Position FTE

• Filter on Position Status 
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Create a PivotTable
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Select all data, then 
from the Insert Tab, 
select PivotTable  

Leave the Create 
PivotTable prompt as 
defaulted  and click “OK”



Choose PivotTable Fields  

43

In the PivotTable Fields box move
1. Position Status in the Filters Box
2. Position Description to the Rows Box
3. Building IRN to the Columns Box 
4. Position FTE to the Values Box (be sure it 

says “Sum of”) 



CK Record PivotTable
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Select the data in the PivotTable, 
then from the Home Tab select the 
Borders icon and the “All Borders”



Position Status Filter 
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Position Status Element Options 
C - Current position in the district 
A - Contracted personnel - Agency 
I - Contracted personnel - Individual 
P - Leave of absence 
U - No longer employed by district 
in this position 

1. From the dropdown 
select appropriate Position 
Statuses to include (check 
“Select Multiple Items” to 
make individual selections), 
then click “OK”

In most instances it would be best to 
not include “P” and “U” in the filter



CK Record PivotTable
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Use this PivotTable 
as a high-level view 
of current staff by 
Position Code and 
Position FTE by building

Drill down to 
staff level data 
by clicking 
specific values  



Quick Check • Did you successfully create a simple 
PivotTable?

• Are you able to drill down to staff level 
data? 

• Who in your district might like to see a 
summary of staff data? 

PivotTables are an effective tool 
to summarize and use in the 
data review process. Data can 
easily be drilled down to staff 
level data. Administrators often 
appreciate high level summary 
data such as the PivotTable we 
just created. 
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Accessing Recorded
Excel Sessions 
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EMIS Alliance Public Space 
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This website contains ODE ITC 
Conference Call notes, EMIS Alliance 
Instructional Videos, and a calendar 
of upcoming EMIS Alliance Trainings



FY21 Excel Video 

• Enrollment Headcount Summary Report
• Best Practices

• Enrollment Headcount Detail Report
• PivotTable Ideas   

• FTE Detail Report
• PivotTable Example
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FY20 Excel Video

• Simple formulas to troubleshoot student FTEs

• VLOOKUP to add LEA names to a report 

• Macro to format an FTE Detail report 

• Concatenation and conditional formatting to verify calendar 
data and student data 
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FY19 Excel Video

• Create a Macro to Format a Spreadsheet

• Calendar Data Verification

• Create a Dropdown List in Excel

• FTE Detail Report Subtotaling 
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FY18 Excel Video

• ODDEX Student Cross Reference (SCR) Export 

• Calendar and Student Data Comparison 

• Staff Data Formatting to Share with District Staff

• FTE Detail Report Subtotaling 

• FTE Detail Report PivotTable 
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Summary

• Basic Excel techniques can be very useful when 
troubleshooting
• EMIS data in the Student Information System

• EMIS reports

• These techniques should be part of your everyday 
practices
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Resources

• EMIS Manual 

• Access previous EMIS Alliance sessions 
• https://community.mcoecn.org/display/EM/EMIS+Alliance+Public

+Space

• Microsoft Excel Help within Excel “?” Articles and Videos

• Google it 

• Microsoft Excel Classes

• Your ITC

55



56

Questions?
If you would like a certificate of attendance for this 

training, you must complete the below feedback form 
within 5 business days of this training
https://tinyurl.com/EA-District-Feedback

https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftinyurl.com%2FEA-District-Feedback&data=04%7C01%7Ctammyhrosch%40metasolutions.net%7C1ffc7cb91444482682a808d968c965ab%7Ca2b91a638b914657a89212e8f42ed79c%7C0%7C0%7C637656036474783411%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2BLOxwQTPwvKI1G%2FtLDrBW000JdyqS8QPohAjh7llCPE%3D&reserved=0

